World 0-1 of Super Mario Bros.

In Super Mario Bros.

I use the emulator NESTOPIA and when I drag and drop the NES ROM of SMB on it, sometimes the world 0-1 appears. (not always) It's a weird green water world with only 1 enemy (a flower) and when you clear it it comes all over again.
Did anyone encounter the same thing?

I have NEStopia for Mac, I'm going to see if I can make it happen too.

It happens more often with the Chinese version that I have for SMB...
I also made screenshots, but unfortunately I don't have webspace to load them up.

Weird. That sounds different than the REGULAR "minus world" glitch. The regular minus world is exactly like 2-1, but when you exit, you start at the beginning of the level again. Also, the level is displayed like -1. I have a Mac as well. I might try this out.

It's a quite weird world. 0-1, and you have to play it over and over again once you start it.

I haven't used NESTOPIA yet, but I'm sure they have the capabilities of taking screenshots. Could you take a screenshot for us and post it?

a fine idea Roth. since I can't seem to get it to happen.

Since I don't have webspace I sent two screens by mail to Derek, our leade... ah... admin.
Perhaps he can post them somewhere.

Anybody knows a good free webspace provider (that works and with not too many ads)?

my avatar is hosted at they seem to do pretty well, no ads or anything to contend with, just upload your file, and copy the link they give you.

Not too many really good ones, but there are some sites where you can upload your pics for free. I can't remember the name of the site, but a number of people here use it. I believe NES-Luke could give us the link.

beat you to it

Thank you. I'll try it.

Since I don't have webspace I sent two screens by mail to Derek, our leade... ah... admin.
Perhaps he can post them somewhere.

Anybody knows a good free webspace provider (that works and with not too many ads)?

I'm betting there's a simple open source package I could get for Linux/Apache that I can do this for users-- for images, at least. Anyone know of anything? It would obviously have to be secure and have quotas/limits for accounts... Thanks.


This is the first thing I stumbled upon. I'm not sure about all the specs. It says it's for PHP, but since phpBB is written in PHP, maybe you could use it?

I've said it before, I don't know much about the PHP thing...

This is the first thing I stumbled upon. I'm not sure about all the specs. It says it's for PHP, but since phpBB is written in PHP, maybe you could use it?

I've said it before, I don't know much about the PHP thing...

Well, I'm really looking for something that I can create user accounts, let those people manage their own space, etc. With limitations, etc. php will work, yes.


I wasn't sure if that would work. I saw it said you could allow friends and family to upload pics, but I wasn't sure if that was by account or not. I also wasn't sure about the security aspect, either.

I am new here but I took some screenshots of world 0-1 for you all. I apoligize for the quality and for my taskbar showing in them. enjoy...


I just got it to work, also!!! I just did the drag-and-drop thing in FCE Ultra! It worked everytime I tried it! That's crazy!

I told you it's cool.

Are there more glitches in other games you can access by drag and drop? I should try some time...

Arrrrggg! Can't get it to work! I've been trying for EVER! This is a SINGLE copy of SMB, right? Not any of the split cartridges? (SMB/Duckhunt for example).

WEIRD. I finally downloaded a different copy of the NES ROM, and it works EVERY time now in FCEUltra. Even stranger, it DOESN'T work in nnNesterJ. I took some cleaner screens for everybody to check out. Take a look at the 6th screen. It's possible to get STUCK in the level if you take the top route. Cool find, manuel.

That's a cool series of screens you made there.

Yeah, that was the first one I tried, too. I wonder exactly what it is that makes it different?

certainly interesting. there are two bonus worlds that weren't actually supposed to be playable in the game, but are in there and some odd way, accessible.

Seeing as how these are just NES ROM dumps, I wonder how it can be accessed on the cartridge?

Well, world -1 can be accessed on the cart (Roll has done it, I can't seem to ) but this one I'm not so sure about...

You would think that somebody would've stumbled onto it at some point... It may also be only on certain carts (i.e. Super Mario Bros. but not Super Mario Bros./Duckhunt). I'll have to try and find some walls to try and jump through, or something.

maybe it's just the way the emulator opens the NES ROM or something that makes it go to that level, as stated it only does it when you drag and drop the NES ROM. so we know the level is in there, but accessing it on the real cart may very well be impossible.

I'm wondering if maybe it was a test level for Mario's swimming ability (since 1984 ). Maybe they just never removed it. I've heard of the same kind of thing on SMB 3, though I haven't looked to much into it...

that's entirely possible, test levels are rarely removed from the final product unless space is a big concern.

Now I'm wondering if this is possible (I don't know much about this, but here goes). Maybe through a different mapper? I'm not entirely sure how those work, but maybe something else can be accessed through those. I wouldn't even know where to start, or if that can be done...

I doubt you could use a different mapper, the game code funtioning properly is very reliant on the mapper as far as I know. for example, the MMC5 mapper, the most crazy one that was only used on two games (Kirby's Adventure, and Castlevania III) is responsible for the great graphics and scrolling in those games. it's the mapper that prevents SMB from being able to scroll backward.

I'll have to do more research, but I was thinking there was more than one mapper for each kind of chip. That'd be interesting to find out...

to my knowledge the mapper is contained on a separate chip inside the cart.

Ah... you're probably right. I'd really like to find out about this. I'm definately going to Google later on!

I tried the glitch on two copies of the SMB NES ROM (no splits), and only one of them worked. It makes me wonder if it's an unoriginal NES ROM. If this level IS on the cartridge, it might be possible to play it on the NES with a Game Genie.

Now, how would we figure something like that out? I know there are ways to make cheats in emulators through hex, is that how the Game Genie is programmed? Maybe there's a way to get into the NES ROM to try and figure out where it's at. Is there a way to view a NES ROM in a text editor? Or maybe it being an image won't help. I don't know... darn it! Wish I had more know-how...

yes, the game genie uses Hex as I recall, there are a few emulators that have a code searching feature. but they generally just search the hex that's being sent from the NES ROM at that point in time. Perhaps if one were to use an emulator with the searcher. And play with codes during level loading it could be uncovered. once the proper game genie code was deciphered using the emulator it would work on the actual console assuming the NES ROM and cart are the exact same.

OK, I've also played the level, and that is very weird. I haven't seen that one documented anywhere before.

The Game Genie code already exists.

Taken from Game Genie Code Oddities ()

"Level Select" code!! Lets you start on any world you want! Here is how to get to the level select screen: When you first start out, you are in a new world (0-1) and you have to finish this level to get to the level select screen. Here's how: Swim (yes swim) past the first pipe you see and keep going until you see some water at the bottom of the screen. Swimover the top of the blocks that are above the water, but not too far. Then swim down and backwards a little to drop down through the little opening in the blocks that lets you get to the bottom of the screen. This part is very important because if you aren't at the bottom part of the screen, you won't be able to finish the level. Once you get to the lower part of the screen,just keep going to the end of the level. When you get to the end, it will say "Thank You Mario, but our Princess is in Another Castle". To get the game to continue, you have to press"B". Now your at the "Level Select" screen! Just press "B" until you see the world you want (at the top of the screen), and then press "Start".

I had tried this out a few weeks ago on the SMB/Duckhunt and stand alone versions of the game and it definitely worked.

Ah... well, there's the answer to our question! Thanks, cracked8ball!

Guess I'll have to check that out when I finish with Megaman 2

World 0 is accessable from the origional nintendo on world 1 level 2. What you have to do is go to where the level ends, and instead of going over the top to get to the warp chamber you have to go through the walls, if you enter a tube before the "select your world" screen comes up it I beleive the first tube takes you to world 0 the second takes you to world 4 and the third takes you to world 5.

So the way to go through the wall is right before you jump over the wall to go to the warp zone, go to the bottom area where the normal level exit is and instead of going through the tube hop on top. There should be 2 blocks overhead, (the roof) you need to break the one one the left, but LEAVE the one on the right (against the wall) in tact. Yes you must be big in order for this trick to work. So after stay on top of the pipe, move as far to the left as you can without falling off, now press and hold down, jump to the right and while in the air let go of the down button.

This was already hard to do on the origional nintendo, so it might be impossible on the NES ROM's. It usually takes at least 40-50 attempts to get through the wall, sometimes you can waste all the time trying to do it and still not get through. Just keep trying.

If done correctly you should travel through the brick wall, and be able to select one of the tubes before the numbers above the tubes come up.

I know they did take this out when they revamped the marios into the super nintendo, so it must not have been supposed to be there?

Well good luck.

@joyu - Doing that takes you to -1, not world 0. the negative world was
just a repeating underwater world.
Also the the first and thrid pipes took you there. The middle one took
you to lvl 5. No doubt due to the fact that on another warp lvl with the
single pipe in the center that took you to 5. (note that on that lvl, if you
do the walk thru wall trick to get to the single pipe in the middle it will
still take you to lvl 5)
Also to note you don't need to stand on the very edge of the pipe to
get through the wall. You can almost stand anywhere on the pipe.
I think you need to be squating and jump backwards.
I have two 'movies' i made that play on nesticle showing how to get thru
the wall. goto

To use these files, click esc or space bar while in nesticle. goto CPU->nes movie->play
and type in the file name. Press stop once you see mario went thru the wall to end the
movie if you want to get to the warp area. Or press alt-p to pause it then stop the
movie. (I only made the files as a demostration for myself if I later on wanted to know
how to get there. So I jump out and try again and again)

Also it does look like a glitch that's not supposed to be there. It would've
been too hard for them to have done that on purpose and it's a glitch
they would eaisly have missed.

This is the whole pic of 0-2. (for me 0-1 is the start lvl 1-1.

That's a nice level map you made there.

wlel that pretty cool hmmm though the minus world had to be made on purpose why? because the try he FAMICOM disk system version of the Super Mario Bros. and do the same trick you actually have a minus world complete with a dungeon! and when you beat it you go back to the title (screen World 1-1) heh heh. also thi world O-1 just looks like adn underwater 4-4 just with out the programming patterns...

... it sucks. LOL

Oh cool, I didn't know that. So I'll have to grab the famicom disc version? I didn't even know there was a FDS version...

I guess I didn't read all the pages leading up to this, but I have the same problem with my SMB NES ROM. It sucks.

I tried the game genie codes. It put me on 0-1 but it didn't let me select a level.